Joomla! Volunteers Portal

Joomla! 3.6.1

Ennem uuendamist tee kindlasti kodulehest tagavarakoopia!
Kui kasutad Joomla koopiate loomiseks Akeeba Backupi, siis esimese sammuna uuenda see ära 5.1.4 versioonile: https://www.akeebabackup.com/download.html

1. Joomla uuendamine

Uuendamine Joomla! versioonilt 2.5.x

Kahjuks on pisike bugi kui tahetakse uuendada Joomla! 2.5.x versioonile 3.6.0 - see on parandatud versioonis 3.6.1. Samas pole selline migreerimine võimalik - enne tuleb leht viia versioonile 3.5.1 ja siis uuendada versioonile 3.6.0. Edasi juba jätkata sellest lõigust kus räägitakse 3.6.0 uuendamisest 3.6.1 versioonile.

Uuendamine Joomla! versioonilt 3.0.0-3.5.1

Uuenda Joomla! 3.6.0 versiooniks üle uuenduste komponendi: Komponendid - Joomla! update. Edasi juba jätkata sellest lõigust kus räägitakse 3.6.0 uuendamisest 3.6.1 versioonile.

Uuendamine Joomla! versioonilt 3.6.0

Algatuseks uuenda Joomla! uuenduste komponent. Seda saad teha: Lisaprogrammid - Haldamine - Uuenda = Otsi uuendusi. Või siis laed lihtsalt alla ja paigaldad siit: https://github.com/joomla/joomla-cms/releases/download/3.6.1/com_joomlaupdate-3.6.1.zip Peale seda võid lehte uuendada uue komponendiga versioonile 3.6.1. Valmis!

Neile, kes on JUBA uuendanud versiooniks 3.6.1 versioonilt 3.6.0

Midagi lahti ei ole, su leht on uuendatud versioonile 3.6.1. Aga tasuks kontrollida kas andmebaas on ajakohane: Lisaprogrammid - Haldamine - Andmebaas = Paranda.

Neile, kes on JUBA uuendanud versiooniks 3.6.1 versioonilt varasem kui 3.6.0

Failid on uuendatud. Kui kopeerisid need käsitsi, siis pead ka andmebaasi parandajat kasutama.

Kõik versioonid (2.5.4 kuni 3.6.0) - käsitsi uuendamine

Kuigi me seda varianti eriti heaks ei pea, saab Joomlat uuendada ka käsitsi (nagu vanasti Joomla! 1.5 ajal). Selleks on olemas skript koos juhendiga aadressil: https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

2. Probleem emailide peitmisega

Leitud on viga mis varjab emaile robotite eest. Kuniks sellele veel ametlikku paranduspaketti pole, saad seda ise teha järgmise juhendi abil:
https://github.com/joomla/joomla-cms/commit/a5a8140570c9ec32deffb6bb7cfa55da5cbcbde8

3. PHP5.3 probleem

Kui sinu kodulehe server kasutab PHP5.3 versiooni, siis võib esineda administraatori alasse sisse logimisel probleeme. Selle vea saab ära parandada selle juhendi järgi: https://github.com/joomla/joomla-cms/pull/11430/files Muidugi parim variant oleks kasutusele võtta uuem PHP versioon.

Lisaks tutvu Joomla infoga:

https://www.joomla.org/announcements/release-news/5666-the-joomla-3-6-1-update.html
https://www.joomla.org/announcements/release-news/5665-joomla-3-6-1-released.html

Lokaalne foorum pajatab ka meil üht-teist: http://www.eraser.ee/foorum/viewtopic.php?f=54&t=6586